Google

Incident Report for DoIT

Resolved

This incident has been resolved.
Posted Mar 13, 2026 - 11:10 EDT

Investigating

Google Workspace services, including Calendar, Docs, and Drive, are experiencing intermittent error rates in the US region.
Posted Mar 13, 2026 - 10:04 EDT
This incident affected: G Suite (Google Apps) (Google Apps Drive, Google Apps Calendar, Google Apps Docs).