yammer

Incident Report for DoIT

Resolved

Yammer is now using link engage.cloud.microsoft
Posted Jul 01, 2025 - 15:54 EDT

Investigating

Yammer is not currently accessible. System Administrators have been informed.
Posted Jul 01, 2025 - 08:25 EDT
This incident affected: Collaboration and Publishing (Yammer).