TeamDynamix Email

Incident Report for DoIT

Monitoring

TeamDynamix identified a capacity issue impacting the file system and successfully scaled the environment to address it. Email monitoring and attachment uploads are now functioning as expected
Posted Sep 17, 2026 - 22:38 EDT

Investigating

TeamDynamix is currently investigating reports of Email Monitor & Attachment Errors
Posted Sep 17, 2026 - 22:16 EDT
This incident affects: TeamDynamix IT Service Management Platform and TeamDynamix Email.