DUO admin

Incident Report for DoIT

Resolved

This incident has been resolved.
Posted Sep 09, 2025 - 13:23 EDT

Monitoring

A fix has been deployed for the issue causing login failures on cross deployment logins to the Duo Admin Panel and we are monitoring the results.
Posted Sep 09, 2025 - 13:05 EDT

Investigating

- We have identified an issue causing login failures on cross deployment logins to the Duo Admin Panel on multiple deployments. We are working to correct the issue as soon as possible.
Posted Sep 09, 2025 - 13:04 EDT
This incident affected: Accounts and Passwords (Duo Security Two-Factor Authentication).